re = /^(h[1-6]|p|a|img):\n[\w\-\.\d].*(?=\n{0,}?)/m
str = 'h3:
Lorem, ipsum dolor, sit amet consectetur adipisicing elit. Voluptate, perspiciatis.
h4:
Lorem, ipsum dolor, sit amet consectetur adipisicing elit. Voluptate, perspiciatis.
p:
Hello this is a paragraph you can add something to our dsle deglet for more and now how to use this for free
img:
http://www.icon.in/logoe/gksoedfkle/dfkeadka/img.jpg
a:
rahul
p:
are you ready for more thing so what do you think
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result