# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(h[1-6]|p|a|img):\n[\w\-\.\d].*(?=\n{0,}?)//gm;t' <<< "h3:
Lorem, ipsum dolor, sit amet consectetur adipisicing elit. Voluptate, perspiciatis.
h4:
Lorem, ipsum dolor, sit amet consectetur adipisicing elit. Voluptate, perspiciatis.
p:
Hello this is a paragraph you can add something to our dsle deglet for more and now how to use this for free
img:
http://www.icon.in/logoe/gksoedfkle/dfkeadka/img.jpg
a:
rahul
p:
are you ready for more thing so what do you think
"