// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)access[.]log[.]{0,1}[0-9]{0,3}[.]{0,1}[a-z]{0,2}").unwrap();
let string = "access.log.100.gz";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}