$re = '/access[.]log[.]{0,1}[0-9]{0,3}[.]{0,1}[a-z]{0,2}/m';
$str = 'access.log.100.gz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);