re = /access[.]log[.]{0,1}[0-9]{0,3}[.]{0,1}[a-z]{0,2}/m
str = 'access.log.100.gz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end