package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)access[.]log[.]{0,1}[0-9]{0,3}[.]{0,1}[a-z]{0,2}`)
var str = `access.log.100.gz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}