re = /[^A-Za-z0-9_\s]/
str = 'Dolce & Gabbana Hamburgers < Pizza < Tacos Sixty > twelve Stuff in "quotation marks" Shindler\'s List <>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end