package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^A-Za-z0-9_\s]`)
var str = `Dolce & Gabbana Hamburgers < Pizza < Tacos Sixty > twelve Stuff in "quotation marks" Shindler's List <>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}