using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^A-Za-z0-9_\s]";
string input = @"Dolce & Gabbana Hamburgers < Pizza < Tacos Sixty > twelve Stuff in ""quotation marks"" Shindler's List <>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}