$re = '/[^A-Za-z0-9_\s]/';
$str = 'Dolce & Gabbana Hamburgers < Pizza < Tacos Sixty > twelve Stuff in "quotation marks" Shindler\'s List <>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);