// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*)\((.*)\) (.*)").unwrap();
let string = "Terence DEMOL (Je dois supprimer à partir de ce message) 06 95 93 94 59";
let substitution = "$3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}