using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)\((.*)\) (.*)";
string substitution = @"$3";
string input = @"Terence DEMOL (Je dois supprimer à partir de ce message) 06 95 93 94 59";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}