$re = '/(.*)\((.*)\) (.*)/';
$str = 'Terence DEMOL (Je dois supprimer à partir de ce message) 06 95 93 94 59';
$subst = "$3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;