const regex = /(.*)\((.*)\) (.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)\\((.*)\\) (.*)', '')
const str = `Terence DEMOL (Je dois supprimer à partir de ce message) 06 95 93 94 59`;
const subst = `$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);