// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\(([a-zA-Z0-9]+)\.([a-zA-Z0-9]+)\))").unwrap();
let string = "2312 (defaultLoan.LoanNumber) asdfasdf (n.3)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}