package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\(([a-zA-Z0-9]+)\.([a-zA-Z0-9]+)\))`)
var str = `2312 (defaultLoan.LoanNumber) asdfasdf (n.3)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}