re = /(\(([a-zA-Z0-9]+)\.([a-zA-Z0-9]+)\))/
str = '2312 (defaultLoan.LoanNumber) asdfasdf (n.3)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end