$re = '/(\(([a-zA-Z0-9]+)\.([a-zA-Z0-9]+)\))/';
$str = '2312 (defaultLoan.LoanNumber) asdfasdf (n.3)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);