re = /<a.+?\s*href\s*=\s*["\']?([^"\'\s>]+)["\']\s*title=["\'](\w+)["\']\s*[>](\w*)[<]?/i
str = '<a href="/test" title="da">test</a>
<a href="/test2" title="adwa">test2</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end