const regex = /<a.+?\s*href\s*=\s*["\']?([^"\'\s>]+)["\']\s*title=["\'](\w+)["\']\s*[>](\w*)[<]?/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a.+?\\s*href\\s*=\\s*["\\\']?([^"\\\'\\s>]+)["\\\']\\s*title=["\\\'](\\w+)["\\\']\\s*[>](\\w*)[<]?', 'gi')
const str = `<a href="/test" title="da">test</a>
<a href="/test2" title="adwa">test2</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}