using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.+?\s*href\s*=\s*[""\']?([^""\'\s>]+)[""\']\s*title=[""\'](\w+)[""\']\s*[>](\w*)[<]?";
string input = @"<a href=""/test"" title=""da"">test</a>
<a href=""/test2"" title=""adwa"">test2</a>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}