package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<a.+?\s*href\s*=\s*["\']?([^"\'\s>]+)["\']\s*title=["\'](\w+)["\']\s*[>](\w*)[<]?`)
var str = `<a href="/test" title="da">test</a>
<a href="/test2" title="adwa">test2</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}