import Foundation
let pattern = #"query (?<collection>.*) query: (?<queryString>.*)planSummary: (?<planSummary>IXSCAN|COLLSCAN).*ntoreturn:(?<ntoreturn>\d+) ntoskip:(?<ntoskip>\d+) nscanned:(?<nscanned>\d+).*nreturned:(?<nreturned>\d+).*reslen:(?<reslen>\d+) (?<duration>.*(?=ms))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2020-04-07T15:46:14.839+0000 [conn205712] query mrfreeze.core_products_platform_3m_test_v4 query: { business_model: "pay_per_circulation" } planSummary: IXSCAN { business_model: 1 } ntoreturn:500 ntoskip:365000 nscanned:365164 nscannedObjects:365164 keyUpdates:0 numYields:60 locks(micros) r:1879126 nreturned:164 reslen:11664 970ms"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}