# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"query (?<collection>.*) query: (?<queryString>.*)planSummary: (?<planSummary>IXSCAN|COLLSCAN).*ntoreturn:(?<ntoreturn>\d+) ntoskip:(?<ntoskip>\d+) nscanned:(?<nscanned>\d+).*nreturned:(?<nreturned>\d+).*reslen:(?<reslen>\d+) (?<duration>.*(?=ms))"
test_str = "2020-04-07T15:46:14.839+0000 [conn205712] query mrfreeze.core_products_platform_3m_test_v4 query: { business_model: \"pay_per_circulation\" } planSummary: IXSCAN { business_model: 1 } ntoreturn:500 ntoskip:365000 nscanned:365164 nscannedObjects:365164 keyUpdates:0 numYields:60 locks(micros) r:1879126 nreturned:164 reslen:11664 970ms"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.