re = /query (?<collection>.*) query: (?<queryString>.*)planSummary: (?<planSummary>IXSCAN|COLLSCAN).*ntoreturn:(?<ntoreturn>\d+) ntoskip:(?<ntoskip>\d+) nscanned:(?<nscanned>\d+).*nreturned:(?<nreturned>\d+).*reslen:(?<reslen>\d+) (?<duration>.*(?=ms))/
str = '2020-04-07T15:46:14.839+0000 [conn205712] query mrfreeze.core_products_platform_3m_test_v4 query: { business_model: "pay_per_circulation" } planSummary: IXSCAN { business_model: 1 } ntoreturn:500 ntoskip:365000 nscanned:365164 nscannedObjects:365164 keyUpdates:0 numYields:60 locks(micros) r:1879126 nreturned:164 reslen:11664 970ms'
# Print the match result
str.match(re) do |match|
puts match.to_s
end