import Foundation
let pattern = #"(BBF10K)(.*)\.(gb|gbk)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/2a_keoni_pip501_transfe.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/2b_orit_oyc.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/3a_ecoli_kanr.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/4_ecoori_cole1pmb1pbr32.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/5_bsubori_pbs72_repa.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/6_cata9.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/7_bsub_laci_laco_promo.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000207.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000210.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000211.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000217.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000227.gb
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)