using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(BBF10K)(.*)\.(gb|gbk)";
string input = @"friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/2a_keoni_pip501_transfe.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/2b_orit_oyc.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/3a_ecoli_kanr.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/4_ecoori_cole1pmb1pbr32.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/5_bsubori_pbs72_repa.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/6_cata9.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/7_bsub_laci_laco_promo.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000207.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000210.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000211.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000217.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000227.gb";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}