package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(BBF10K)(.*)\.(gb|gbk)`)
var str = `friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/2a_keoni_pip501_transfe.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/2b_orit_oyc.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/3a_ecoli_kanr.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/4_ecoori_cole1pmb1pbr32.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/5_bsubori_pbs72_repa.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/6_cata9.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/7_bsub_laci_laco_promo.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000207.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000210.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000211.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000217.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000227.gb`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}