$re = '/([ADFJMNOS]{1,3}\w*\s) ([0-9]{1,2},\s) ([0-9]{4})/mix';
$str = 'April 15, 2015 coordinating committee';
$subst = "\1\2\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;