#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mix)([ADFJMNOS]{1,3}\w*\s) ([0-9]{1,2},\s) ([0-9]{4})"
Local $sString = "April 15, 2015 coordinating committee"
Local $sSubst = "\1\2\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)