using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([ADFJMNOS]{1,3}\w*\s) ([0-9]{1,2},\s) ([0-9]{4})";
string substitution = @"\1\2\3";
string input = @"April 15, 2015 coordinating committee";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}