use strict;
my $str = 'April 15, 2015 coordinating committee';
my $regex = qr/([ADFJMNOS]{1,3}\w*\s) ([0-9]{1,2},\s) ([0-9]{4})/mixp;
my $subst = '\\1\\2\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";