// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\+?[0-9]{0,3}-?[0-9]{7,10}$").unwrap();
let string = "happy cases:
+919876576543
+91-9876576543
91-9876576543
919876576543
9876576543
sad cases:
+91 9773938389
91 9773938389
97739 75647
(+91)-9876576543
(+91)9876576543
(91)9876576543";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}