use strict;
my $str = 'happy cases:
+919876576543
+91-9876576543
91-9876576543
919876576543
9876576543
sad cases:
+91 9773938389
91 9773938389
97739 75647
(+91)-9876576543
(+91)9876576543
(91)9876576543';
my $regex = qr/^\+?[0-9]{0,3}-?[0-9]{7,10}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}