#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+?[0-9]{0,3}-?[0-9]{7,10}$"
Local $sString = "happy cases:" & @CRLF & _
"+919876576543" & @CRLF & _
"+91-9876576543" & @CRLF & _
"91-9876576543" & @CRLF & _
"919876576543" & @CRLF & _
"9876576543" & @CRLF & _
"" & @CRLF & _
"sad cases:" & @CRLF & _
"+91 9773938389" & @CRLF & _
"91 9773938389" & @CRLF & _
"97739 75647" & @CRLF & _
"(+91)-9876576543" & @CRLF & _
"(+91)9876576543" & @CRLF & _
"(91)9876576543"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")