re = /^\+?[0-9]{0,3}-?[0-9]{7,10}$/m
str = 'happy cases:
+919876576543
+91-9876576543
91-9876576543
919876576543
9876576543
sad cases:
+91 9773938389
91 9773938389
97739 75647
(+91)-9876576543
(+91)9876576543
(91)9876576543'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end