# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\-(((ae|as)|(ge|et|xe)\-\d\/\d\/)\d+(:\d){0,1}\.\d+)"
test_str = ("policerdrop-bs.[lim2m-xe-0/0/1.10106-inet-i] \n"
"policerdrop-bs.[lim256k-ge-2/0/0.159-inet-i] \n"
"policerdrop-bs.[lim256k-ae2.159-inet-i] \n"
"policerdrop-bs.[lim2m-xe-0/0/1:0.10106-inet-i] \n\n"
"policerdrop-bs.[limbw-1m-xe-1/0/0.6027-inet-i]")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.