#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\-(((ae|as)|(ge|et|xe)\-\d\/\d\/)\d+(:\d){0,1}\.\d+)"
Local $sString = "policerdrop-bs.[lim2m-xe-0/0/1.10106-inet-i] " & @CRLF & _
"policerdrop-bs.[lim256k-ge-2/0/0.159-inet-i] " & @CRLF & _
"policerdrop-bs.[lim256k-ae2.159-inet-i] " & @CRLF & _
"policerdrop-bs.[lim2m-xe-0/0/1:0.10106-inet-i] " & @CRLF & _
"" & @CRLF & _
"policerdrop-bs.[limbw-1m-xe-1/0/0.6027-inet-i]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")