use strict;
my $str = 'policerdrop-bs.[lim2m-xe-0/0/1.10106-inet-i]
policerdrop-bs.[lim256k-ge-2/0/0.159-inet-i]
policerdrop-bs.[lim256k-ae2.159-inet-i]
policerdrop-bs.[lim2m-xe-0/0/1:0.10106-inet-i]
policerdrop-bs.[limbw-1m-xe-1/0/0.6027-inet-i]';
my $regex = qr/\-(((ae|as)|(ge|et|xe)\-\d\/\d\/)\d+(:\d){0,1}\.\d+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}