import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\-(((ae|as)|(ge|et|xe)\\-\\d\\/\\d\\/)\\d+(:\\d){0,1}\\.\\d+)";
final String string = "policerdrop-bs.[lim2m-xe-0/0/1.10106-inet-i] \n"
+ "policerdrop-bs.[lim256k-ge-2/0/0.159-inet-i] \n"
+ "policerdrop-bs.[lim256k-ae2.159-inet-i] \n"
+ "policerdrop-bs.[lim2m-xe-0/0/1:0.10106-inet-i] \n\n"
+ "policerdrop-bs.[limbw-1m-xe-1/0/0.6027-inet-i]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}