// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*liferay.*deploy-hot.*").unwrap();
let string = "axa-es-liferay/ned/preprod/int/deploy-hot
axa-es-liferay/ned/dev/des/deploy-hot
axa-es-liferay/portales/dev/des/deploy-hot
axa-es-liferay/portales/dev/des/deploy-develop";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}