re = /^.*liferay.*deploy-hot.*/m
str = 'axa-es-liferay/ned/preprod/int/deploy-hot
axa-es-liferay/ned/dev/des/deploy-hot
axa-es-liferay/portales/dev/des/deploy-hot
axa-es-liferay/portales/dev/des/deploy-develop'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end