#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*liferay.*deploy-hot.*"
Local $sString = "axa-es-liferay/ned/preprod/int/deploy-hot" & @CRLF & _
"axa-es-liferay/ned/dev/des/deploy-hot" & @CRLF & _
"axa-es-liferay/portales/dev/des/deploy-hot" & @CRLF & _
"axa-es-liferay/portales/dev/des/deploy-develop"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")