package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*liferay.*deploy-hot.*`)
var str = `axa-es-liferay/ned/preprod/int/deploy-hot
axa-es-liferay/ned/dev/des/deploy-hot
axa-es-liferay/portales/dev/des/deploy-hot
axa-es-liferay/portales/dev/des/deploy-develop`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}