re = /^([+-]?)([√∛∜]|a?(?:sin|cos|tan)h?|cot|sec|csc|ln|log(?:2|10)?)?([([{⎢])/i
str = '-asin(-1)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end