const regex = /^([+-]?)([√∛∜]|a?(?:sin|cos|tan)h?|cot|sec|csc|ln|log(?:2|10)?)?([([{⎢])/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([+-]?)([√∛∜]|a?(?:sin|cos|tan)h?|cot|sec|csc|ln|log(?:2|10)?)?([([{⎢])', 'i')
const str = `-asin(-1)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}