package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^([+-]?)([√∛∜]|a?(?:sin|cos|tan)h?|cot|sec|csc|ln|log(?:2|10)?)?([([{⎢])`)
var str = `-asin(-1)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}