#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^([+-]?)([√∛∜]|a?(?:sin|cos|tan)h?|cot|sec|csc|ln|log(?:2|10)?)?([([{⎢])"
Local $sString = "-asin(-1)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")