import Foundation
let pattern = #"^([A-Z][a-z]+)+((__([a-z]+[A-Z]?)+)(--([a-z]+[A-Z]?)+)?)?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
TitleCaseName
TitleCaseName__element
TitleCaseName__element--modifier
TitleCaseName--modifier
TitleCaseName__element__modifier
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}