import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Z][a-z]+)+((__([a-z]+[A-Z]?)+)(--([a-z]+[A-Z]?)+)?)?$";
final String string = "TitleCaseName\n\n"
+ "TitleCaseName__element\n\n"
+ "TitleCaseName__element--modifier\n\n"
+ "TitleCaseName--modifier\n\n"
+ "TitleCaseName__element__modifier";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}